Jump to content

The ultimate community for Ruby on Rails developers.


Photo

Old release caching


  • Please log in to reply
1 reply to this topic

#1 YuVDM

YuVDM

    Passenger

  • Members
  • 1 posts

Posted 17 October 2013 - 12:26 PM

Hi all,

for first sorry for my english.

I've deployed a new app release with Capistrano on my Server after a cap
deploy:cleanup (just to delete some old releases).

At the moment I can't see the changes I've made because It seems that
and old release with a "tmp/cache/..." folders structure "win" against
my latest current release.

So on the filesystem I've got

current -> /correct_latest_release_timestamp
releases
- latest release
... other releases
- old bad release

I've tried to delete the old bad release directory but every time a make
an http call to my App that folder return with root user permission
(Linux Server) but I don't Know why and from whom.



#2 james

james

    Guard

  • Moderators
  • 221 posts
  • LocationLeeds, U.K.

Posted 31 October 2013 - 04:23 PM

Just a quick thought.

Did you restart your server as part of your deployment script? Look for any errors in the cap deploy output to make sure the deployment actually worked and didn;t just roll back on a failure


Programming is just about problem solving!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users