Jump to content

The ultimate community for Ruby on Rails developers.


Photo

git push heroku master - require passphrase

heroku

  • Please log in to reply
3 replies to this topic

#1 dailammoc

dailammoc

    Dispatcher

  • Members
  • 36 posts
  • Location/

Posted 11 March 2014 - 09:17 AM

Hi all, today I learned to deploy my project using heroku. When I type:

git push heroku master

the heroku promt to enter passphase:

Enter passphrase for key '/home/hien/.ssh/': 

I'm very confused because when I tried to type either my heroku's password or leave it blank it did work. I also tried to remove all keys on ~/.ssh/ fordel and regenerate but nothing chages. So can some one tell me how to solve this problem?



#2 r619

r619

    Passenger

  • Members
  • 1 posts

Posted 18 March 2014 - 07:08 PM

Try entering the password for the computer, the one you use during login.


Sent from my iPad using Tapatalk
Using Tapatalk

#3 dailammoc

dailammoc

    Dispatcher

  • Members
  • 36 posts
  • Location/

Posted 19 March 2014 - 08:08 AM

I tried to type my computer's password, but this cannot solve my problem...



#4 Jamie

Jamie

    Controller

  • Moderators
  • 140 posts
  • LocationNewcastle, UK

Posted 28 March 2014 - 05:58 PM

If you're using GitHub I'd also have a look at https://help.github....rating-ssh-keys

 

For use with Heroku, please refer to the documentation here https://devcenter.he...m/articles/keys

 

That'll help you reset. I've normally left it blank and whenever it's asked me for it, and pressing return has remembered the keyphrase.

 

Good luck!


Rails developer based in Newcastle, UK.






Also tagged with one or more of these keywords: heroku

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users