Jump to content

The ultimate community for Ruby on Rails developers.


Photo

Error when checking Rails version and starting server

server error rails

  • Please log in to reply
1 reply to this topic

#1 amyers

amyers

    Passenger

  • Members
  • 4 posts

Posted 27 January 2014 - 06:44 AM

When I try the "rails -v" command in Terminal, while in my project's directory, I get the following error:

bin/rails:4:in require: cannot load such file -- rails/commands (LoadError) from bin/rails:4:in <main> 

I was/am having trouble getting rails server to start, so I attempted to check my version. Does anyone have any idea what this means? I'm on Mac osx 10.7.5 and ruby 2.0. I know I had Rails 4.0.2 installed, but don't know what this means. 

 

Does anyone have any idea what I can do?



#2 amyers

amyers

    Passenger

  • Members
  • 4 posts

Posted 27 January 2014 - 07:15 AM

Ok, so I found out that my gemfile within my project was empty, but gemfile.LOCAL had all the gems listed inside it. I had to add the Rails gem into the empty gemfile.   Does anyone have any idea why that would be? And what is the difference between the two?







Also tagged with one or more of these keywords: server, error, rails

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users