Jump to content

The ultimate community for Ruby on Rails developers.


Photo

rails server erro

rails rails4

  • Please log in to reply
1 reply to this topic

#1 paveytel

paveytel

    Signalman

  • Members
  • 12 posts

Posted 27 December 2013 - 04:45 AM

When I run rails server, I have the following error:

rails server
=> Booting WEBrick
=> Rails 4.0.2 application starting in development on localhost:3000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
[2013-12-26 23:29:07] INFO WEBrick 1.3.1
[2013-12-26 23:29:07] INFO ruby 2.0.0 (2013-11-22) [i386-mingw32]
[2013-12-26 23:29:07] WARN TCPServer Error: Only one usage of each socket address (protocol/network address/po
rt
) is normally permitted. - bind(2)
Exiting
C:/Ruby200/lib/ruby/2.0.0/webrick/utils.rb:85:in `initialize': Only one usage of each socket address (protocol/
network address/port) is normally permitted. - bind(2) (Errno::EADDRINUSE)
from C:/Ruby200/lib/ruby/2.0.0/webrick/utils.rb:85:in `
new'
from C:/Ruby200/lib/ruby/2.0.0/webrick/utils.rb:85:in `block in create_listeners'

from C:/Ruby200/lib/ruby/2.0.0/webrick/utils.rb:82:in `each'
from C:/Ruby200/lib/ruby/2.0.0/webrick/utils.rb:82:in `
create_listeners'
from C:/Ruby200/lib/ruby/2.0.0/webrick/server.rb:132:in `listen'

from C:/Ruby200/lib/ruby/2.0.0/webrick/server.rb:113:in `initialize'
from C:/Ruby200/lib/ruby/2.0.0/webrick/httpserver.rb:45:in `
initialize'
from C:/Ruby200/lib/ruby/gems/2.0.0/gems/rack-1.5.2/lib/rack/handler/webrick.rb:11:in `new'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/rack-1.5.2/lib/rack/handler/webrick.rb:11:in `run'
from C:/Ruby200/lib/ruby/gems/2.0.0/gems/rack-1.5.2/lib/rack/server.rb:264:in `
start'
from C:/Ruby200/lib/ruby/gems/2.0.0/gems/railties-4.0.2/lib/rails/commands/server.rb:84:in `start'

from C:/Ruby200/lib/ruby/gems/2.0.0/gems/railties-4.0.2/lib/rails/commands.rb:76:in `block in <top (req
uired)>'
from C:/Ruby200/lib/ruby/gems/2.0.0/gems/railties-4.0.2/lib/rails/commands.rb:71:in `
tap'
from C:/Ruby200/lib/ruby/gems/2.0.0/gems/railties-4.0.2/lib/rails/commands.rb:71:in `<top (required)>'

from bin/rails:4:in `require'
from bin/rails:4:in `
<main>



#2 james

james

    Guard

  • Moderators
  • 221 posts
  • LocationLeeds, U.K.

Posted 27 December 2013 - 02:34 PM

You don't need to run ore than one server at a time. I yuour server is already running then you don't need to start the server again


Programming is just about problem solving!






Also tagged with one or more of these keywords: rails, rails4

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users