Jump to content

The ultimate community for Ruby on Rails developers.


Error on Bundle install

  • Please log in to reply
3 replies to this topic

#1 EPanda



  • Members
  • 1 posts

Posted 16 August 2013 - 02:58 AM

Hello everyone i am having a trouble fixing this error. 

Everytime i run 

bundle install

it prompts me 

  C:/Sites/RailsInstaller/Ruby1.9.3/bin/ruby.exe extconf.rb
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
Checking for Python...Unable to build libv8: Python not found!

Gem files will remain installed in C:/Sites/hw2_rottenpotatoes/path/ruby/1.9.1/g
ems/libv8- for inspection.
Results logged to C:/Sites/hw2_rottenpotatoes/path/ruby/1.9.1/gems/libv8-3.3.10.
An error occurred while installing libv8 (, and Bundler cannot
Make sure that `gem install libv8 -v ''` succeeds before bundling.

what should i do this thing?

thank you.... :)


#2 Kelli Shaver

Kelli Shaver


  • Administrators
  • 76 posts
  • LocationKentucky

Posted 16 August 2013 - 03:07 AM

Do you have Python installed?

#3 Stuart Hannig

Stuart Hannig


  • Members
  • 15 posts

Posted 16 August 2013 - 03:36 AM

Looks like you need to install Python for that library to work. Did you run the command `gem install libv8 -v ''? Did it keep erroring out? Windows is a fragile system to do Ruby development work because some gems don't work properlly. If you need to use that gem and can't find a way getting it installed, I'd suggest using Nitrous.io as a web IDE. It worked great for me when needing to use SQLite3 gem and Ruby 2.0, which doesn't work all to well on Windows at the moment.


Best of luck!

#4 Beltran



  • Members
  • 2 posts

Posted 16 August 2013 - 09:53 AM

You can also try BitNami Ruby Stack that ships all the required dependencies for starting with Ruby on Rails on Windows. It does not require Python installed.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users